Upgrade Information for Dental4Windows
See instructions below for What Dental4Windows Build am I running?, Check if an Upgrade is available to run, Download and Run an Upgrade, Download Upgrade to run at a later time and System Error Code 0 when Upgrading D4W/PSS Client.What Dental4Windows Build am I running?
Check the build you are running, from any screen within Dental4Windows.
- Help menu > About

- Within the 'About Dental4Windows SQL' window, the build number is located at the top right

D4W/PSS: Check if an Upgrade is available to run
Checking for updates can be completed both manually and automatically.
On a client computer, checking for updates is permitted, however downloading upgrades is only possible from the server.
Automated Check Prompt
Based on the frequency setup in Setup Internet Upgrade, the following prompt will appear on selected computers.

Yes: Proceed to check for updates
No: Do not check for updates
Don't prompt me again for 30 days on this computer: Tick to pause the prompt for 30 days on this computer
Don't prompt on all computer for 30 days: Tick to pause the prompt for 30 days on all computers
Manual Check
Go to Help menu > Check for Updates

Upgrade Status
- If the system is already on the most up to date version, the following window will appear

- If the system can be upgraded, the following window will appear

Checking for updates can be completed both manually and automatically. To turn on automated checks, see Preferences - Application section,
On a client computer, checking for updates is permitted, however downloading upgrades is only possible from the server.
Automated Check Prompt
Based on the frequency setup in Preferences - Application, the following prompt will appear on selected computers.

Yes: Proceed to check for updates
No: Do not check for updates
Don't prompt me again for 30 days on this computer: Tick to pause the prompt for 30 days on this computer
Don't prompt on all computer for 30 days: Tick to pause the prompt for 30 days on all computers
Manual Check
Go to Help menu > Check for Software Updates

Upgrade Status
- If the system is already on the most up to date version, the following window will appear

- If the system can be upgraded, the following window will appear

Download and Run an Upgrade
After checking for an upgrade, per Check for Internet Upgrade instructions above, follow the below steps.
- Complete these steps on the server computer
- If prompted at any stage by a message about Antivirus, Firewalls or Spyware throughout the upgrade, select to unblock or allow to continue.
- Select Download and Upgrade > Click Next

- Files will begin to download, per the below window

- Select Yes to continue with upgrade now

- Follow the prompts until the Validate window appears
- Select Full Validation > Click Next

In the next UPM window DO NOT click Upgrade button or any other button even if it looks like it has frozen or isnt responding, this is an automated process
- The UPM window will close and continue when completed

- Next, run the upgrade on each of your client computers
Database Mismatch message
- Start D4W on a client computer.
- A mismatch message will appear
- Click OK

- Follow the prompts (repeat at each client computer)
Download Upgrade to run at a later time
After checking for an upgrade, per Check for Internet Upgrade above and wanting to download but not process the upgrade yet, follow the below steps.
If a stoppage occurs in the following screens, follow the Manual Check for Updates steps to start again.
Download
- Select Download Only > Click Next

After reading, click OK to proceed

Files will begin to download, per the below window

Run Upgrade
The following instructions must be completed on the Server computer.
- Go to Help > Check for Updates
- Click Next > Click Yes to proceed with upgrade

- Follow the prompts until the Validate window appears
- Select Full Validation > Click Next

- In the next UPM window DO NOT click Upgrade button or any other button even if it looks like it has frozen or isnt responding, this is an automated process
- The UPM window will close and continue when completed

- Next, run the upgrade on each of your client computers
System Error Code 0 when Upgrading D4W/PSS Client
Error:
System Error code - 0 The operation completed successfully

Cause:
This error is usually caused by permission issues or the upgrade path not being configured correctly.
Fix:
Right click the D4W/PSS icon on the desktop and select Run As Administrator

If the error persists, ensure shared out files on the server are accessible.
- Open File Explorer
- In the address bar, type in \\ followed by the name of the server e.g \\myserver

- Press Enter on the keyboard to load the shared folders on the server computer
- If it doesn't or gives an error, please contact the practice's IT person to resolve
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