Upgrade Information for D4W

Upgrade Information for D4W

QuoteSee instructions below for What Dental4Windows Build am I running?, Check if an Upgrade is available to run, Download and Run an Upgrade, Download Upgrade to run at a later time and System Error Code 0 when Upgrading D4W/PSS Client.

What Dental4Windows Build am I running?

Check the build you are running, from any screen within D4W.
  1. Help menu > About
  2. Within the 'About Dental4Windows SQL' window, the build number is located at the top right

D4W/PSS: Check if an Upgrade is available to run

Checking for updates can be completed both manually and automatically.

InfoTo turn on automated checks, see Activate the Internet Upgrade Feature 

On a client computer, checking for updates is permitted, however downloading upgrades is only possible from the server. 

Automated Check Prompt

Based on the frequency setup in Setup Internet Upgrade, the following prompt will appear on selected computers. 

Yes: Proceed to check for updates
No: Do not check for updates
Don't prompt me again for 30 days on this computer: Tick to pause the prompt for 30 days on this computer
Don't prompt on all computer for 30 days: Tick to pause the prompt for 30 days on all computers

Manual Check

  1. Go to Help menu > Check for Updates

Upgrade Status

  1. If the system is already on the most up to date version, the following window will appear

  2. If the system can be upgraded, the following window will appear

Mediasuite: Check for an Upgrade

Info
Checking for updates can be completed both manually and automatically. To turn on automated checks, see Preferences - Application section,

On a client computer, checking for updates is permitted, however downloading upgrades is only possible from the server. 

Automated Check Prompt

Based on the frequency setup in Preferences - Application, the following prompt will appear on selected computers. 

Yes: Proceed to check for updates
No: Do not check for updates
Don't prompt me again for 30 days on this computer: Tick to pause the prompt for 30 days on this computer
Don't prompt on all computer for 30 days: Tick to pause the prompt for 30 days on all computers

Manual Check

  1. Go to Help menu > Check for Software Updates   

Upgrade Status

  1. If the system is already on the most up to date version, the following window will appear

  2. If the system can be upgraded, the following window will appear

Download and Run an Upgrade

After checking for an upgrade, per Check for Internet Upgrade instructions above, follow the below steps. 

Alert
Important Details
  1. Complete these steps on the server computer
  2. If prompted at any stage by a message about Antivirus, Firewalls or Spyware throughout the upgrade, select to unblock or allow to continue. 
  1. Select Download and Upgrade > Click Next
    1. Files will begin to download, per the below window
    2. Select Yes to continue with upgrade now   
       
    3. Follow the prompts until the Validate window appears
    4. Select Full Validation > Click Next
    5. In the next UPM window DO NOT click Upgrade button or any other button even if it looks like it has frozen or isnt responding, this is an automated process
    6. The UPM window will close and continue when completed

  2. Next, run the upgrade on each of your client computers

Database Mismatch message

  1. Start D4W on a client computer.
  2. A mismatch message will appear
    1. Click OK 

    2. Follow the prompts (repeat at each client computer)

Download Upgrade to run at a later time

After checking for an upgrade, per Check for Internet Upgrade above and wanting to download but not process the upgrade yet, follow the below steps. 
If a stoppage occurs in the following screens, follow the Manual Check for Updates steps to start again.

Download

  1. Select Download Only > Click Next

  2. After reading, click OK to proceed

  3. Files will begin to download, per the below window

Run Upgrade

The following instructions must be completed on the Server computer. 

  1. Go to Help > Check for Updates
  2. Click Next > Click Yes to proceed with upgrade

  3. Follow the prompts until the Validate window appears
  4. Select Full Validation > Click Next

  5. In the next UPM window DO NOT click Upgrade button or any other button even if it looks like it has frozen or isnt responding, this is an automated process
  6. The UPM window will close and continue when completed
  7. Next, run the upgrade on each of your client computers

System Error Code 0 when Upgrading D4W/PSS Client

Error:

System Error code - 0 The operation completed successfully 

Cause:

This error is usually caused by permission issues or the upgrade path not being configured correctly.

Fix:
  1. Right click the D4W/PSS icon on the desktop and select Run As Administrator

If the error persists, ensure shared out files on the server are accessible.

  1. Open File Explorer
  2. In the address bar, type in \\ followed by the name of the server e.g \\myserver

  3. Press Enter on the keyboard to load the shared folders on the server computer
  4. If it doesn't or gives an error, please contact the practice's IT person to resolve
InfoIf shared out files are accessible and the error persists, contact Centaur Support.
    • Related Articles

    • General Dental4Web Information

      General information & descriptions about Dental4Web, including reference number, agent download Find your Customer Reference Number in Dental4Web The customer reference number is a number Centaur uses to identify each practice. It is used to check ...
    • General Information in D4W

      Below is information on How to find the Practice's Customer Reference Number. How to find the Practice's Customer Reference Number The customer reference number is a number Centaur uses to identify each practice. It is used to check current support ...
    • Practice Insights: Information, requirements & security

      Practice Insights (PI) is a Business Intelligence tool for a Dental Business, providing an up to date graphical interpretation of the Business Analysis related to different aspects of your dental practice from the data stored within D4Web. Practice ...
    • National Dental Plan: Information and Prerequisites

      National Dental Plan (NDP) is Australia's only payment plan integrated with the D4W/D4Web software which pays upfront. Important Information Ensure the applicant meets the below criteria set by Humm 18 years of age or older Australian citizen or ...
    • Appointment Book Navigation & information in Dental4Web

      Appointment Book information, toolbar descriptions, navigating & views The Appointment Book Toolbar Toolbar icons descriptions from left to right Go Back by Week or Day Today Date in view Click to bring up the Calendar Go forward by Day, Week, Month, ...